Mobile Originated SMS Messages Are Not Being Received
Incident Report for Airship
Postmortem

Between approximately 10:15AM US Pacific time on 17 March and 2:22PM US Pacific time on 18 March, mobile-originating SMS messages (from end users) were not being delivered correctly, which may have resulted in missed messages back to end users and missing opt-outs. Other SMS/MMS messages continued to be processed and delivered normally. This was due to a bug in a code change that was deployed on the 17th when the issue began. We are currently working with our SMS provider to obtain the lost data so we can update any missing opt-outs for customer devices as soon as possible. We will also be adding monitoring to detect a similar problem more quickly in the future. We apologize sincerely for the inconvenience.

Posted Mar 19, 2020 - 13:30 PDT

Resolved
We have resolved the service issue that prevented end-user mobile-originated SMS messages from being received. All messages are now being received and all systems are operational.

If you have any additional questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Mar 18, 2020 - 14:36 PDT
Investigating
We’re currently investigating an issue that is preventing end-users' mobile-originated messages from being received correctly, which prevents Opting in or out or responding to sent messages.

SMS messages can still be sent using the Airship Dashboard and API.

Our engineering teams are working to identify and resolve this issue. We will update our status page as soon as we have more information.

If you have any additional questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Mar 18, 2020 - 13:55 PDT
This incident affected: SMS Messaging.