Errors When Accessing the Airship Dashboard
Incident Report for Airship
Postmortem

Between approximately 8:55 and 9:32 PM Pacific time on 19 November, our US customer dashboard at https://go.urbanairship.com / https://go.airship.com was inaccessible. Our EU web dashboard was up and operating normally, as well as all of our APIs. The downtime was caused by a bug in the dashboard system that unexpectedly held open database connections, allowing them to proliferate until no more were available. After identifying the problem, our Engineering team brought the dashboard back up and implemented a temporary fix to prevent saturation of connections until we were able to deploy a more detailed fix for the original bug. We apologize sincerely for the inconvenience, and we will be having a postmortem meeting to determine how we can prevent further incidents like this in the future.

Posted Nov 21, 2019 - 07:11 PST

Resolved
We have resolved the issue that resulted in errors when accessing the Airship Dashboard.
Posted Nov 19, 2019 - 22:56 PST
Update
We are continuing to monitor the fix that has been implemented for the issue that resulted in errors when accessing the Airship Dashboard.
Posted Nov 19, 2019 - 22:28 PST
Monitoring
A fix has been implemented for the issue that resulted in errors when accessing the Airship Dashboard at http://go.urbanairship.com and http://go.airship.com.

We are currently monitoring the results.
Posted Nov 19, 2019 - 21:38 PST
Investigating
We are currently investigating an issue that results in errors when accessing the Airship Dashboard at http://go.urbanairship.com and http://go.airship.com. The API is still fully functional.

Our Engineering teams are investigating the issue and are actively working on a resolution.
If you have any additional questions or concerns, please contact Airship Technical Support at https://support.urbanairship.com/.
Posted Nov 19, 2019 - 21:22 PST
This incident affected: Web Dashboard.