Elevated rate of 5xx errors from Airship Push API
Incident Report for Airship
Postmortem

Between 9:54 and 10:46 AM US Pacific time on 22 January , customers on our US cloud site may have encountered an elevated number of 5xx errors and latency from our push API endpoints. This was caused by a short period of reduced capacity resulting from what should have been a standard maintenance operation on this system. The team is investigating why this occurred, why safety mechanisms did not perform as intended, and how we can avoid any repeats of this issue in the future. We apologize for any inconvenience.

Posted Jan 25, 2021 - 07:21 PST

Resolved
Between ~17:54 and 18:46 UTC, Airship’s Push API returned elevated levels of 5xx errors and experienced increased latency.

Airship engineers investigated the issue and were able to mitigate these errors.

Airship’s Push API is now working as expected.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com.
Posted Jan 22, 2021 - 11:41 PST
This incident affected: APIs.