Increased rate of 5xx errors for channel registration and lookups
Incident Report for Airship
Postmortem

Between approximately 9:38 AM and 10:56 AM US Pacific time on 25 June, we experienced an issue on our US cloud site that caused elevated levels of 5xx errors from our channel registration, listing, and lookup APIs, and delayed tag updates and associations for named users. The API issues may have also been noticeable via some failed test device list changes or failed device lookup requests on our go dashboard. Our Engineering team blocked the responsible traffic and is continuing with implementing a plan to better protect and scale the services involved. We apologize for any inconvenience.

Posted Jun 25, 2021 - 15:25 PDT

Resolved
This issue has been resolved.
Posted Jun 25, 2021 - 11:16 PDT
Investigating
We are currently investigating an issue that is causing an increased number of 5xx errors for channel registration, listing, and lookup. Named User associations and updates may also be delayed.

Notifications sent through the API and Go Dashboard are working as expected.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Jun 25, 2021 - 10:17 PDT
This incident affected: Web Dashboard and APIs.