Increased rate of 5XX errors in segment API
Incident Report for Airship
Postmortem

Between approximately 10:13 PM on 24 February and 3:52 AM on 25 February (US Pacific time), customers with accounts on our US cloud site at go.airship.com/go.urbanairship.com would have encountered failures creating, retrieving, and editing segments, as well as sending messages to segments. This was due to an issue with part of the segments system that was unable to recover automatically after scheduled maintenance by our cloud provider. We apologize for any inconvenience, and our Engineering team will be looking into ways to prevent a recurrence during future maintenance events and enhance system monitoring.

Posted Feb 25, 2021 - 16:42 PST

Resolved
We have addressed the issue that was resulting in an increased rate of 5xx errors when using our Segment APIs.

All services are now functioning normally.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Feb 25, 2021 - 04:47 PST
Monitoring
A fix has been implemented. We are currently monitoring the results.

We will update our status page as soon as we have more information.
If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Feb 25, 2021 - 04:05 PST
Investigating
We are currently investigating an issue that is resulting in intermittent failures when accessing segments or sending push targeting segments.
If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Feb 25, 2021 - 03:47 PST
This incident affected: APIs, Mobile Messaging, and Targeting & Personalization.