Channel ID Lookup issue in Go Dashboard
Incident Report for Airship
Postmortem

Between approximately 2:05pm 11 June and 4:55am 12 June US Pacific time, customers using the Airship web dashboard to either target messages by channel ID or look up devices/contacts by channel ID would have encountered an error saying that the channel ID was "Not Available". This was due to an unexpected impact of a code change, and the cause has now been fixed. Our APIs were not impacted. We apologize for any inconvenience.

Posted Jun 18, 2020 - 10:09 PDT

Resolved
The issue that resulted in an error when using the contact lookup tool in the Go dashboard to search for a channel ID and when targeting a specific channel ID has been resolved. All services are now working as expected.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Jun 12, 2020 - 05:07 PDT
Update
We have identified an issue that is resulting in an error when using the contact lookup tool in the Go dashboard to search for a channel ID and when targeting a specific channel ID.

Our engineering teams are working on a fix. We will update our status page as soon as we have more information.

You can use our API to lookup channel IDs or send messages to specific channel IDs.

You can use the Go Dashboard to target named users and tags.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Jun 12, 2020 - 04:21 PDT
Investigating
We are currently investigating an issue that is resulting in an error when using the contact lookup tool in the Go dashboard to search for a channel ID and when targeting a specific channel ID.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

You can use our API to lookup channel IDs or send messages to specific channel IDs.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Jun 12, 2020 - 02:26 PDT
This incident affected: Analytics and Data Solutions (Data Collection & Processing, Engagement Reporting, Real-Time Data Stream, Performance Analytics) and Web Dashboard, www.airship.com, APIs, Mobile Messaging, Web Notifications, Mobile Wallet Passes, Email Messaging, SMS Messaging, Message Center Messaging, Open Channels Messaging, Real-Time Automation, Targeting & Personalization, Orchestration.