Investigating an issue with Email Messaging
Incident Report for Airship
Postmortem

At 9:40am Pacific Time on October 28, 2021 our monitoring began to show traffic increasing in delivery latency by one of our 3rd party Email providers. We were immediately contacted by our account representatives to assist with communicating this issue to customers. They were able to resolve the issue and outbound messages were being delivered as expected beginning at 2:59pm Pacific Time. For the duration of this incident, Email sends using this provider were not delivered to devices and messages were slow to be attempted for delivery. We apologize for any inconvenience this issue may have caused.

Posted Nov 04, 2021 - 06:57 PDT

Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 19:19 PDT
Monitoring
Our 3rd party email provider has identified the issue; outbound message delivery has resumed but it will take time for all queued messages to be delivered.

We will provide updates here as we receive them.

Please feel free to contact Airship Technical Support at https://support.airship.com if you have any questions or concerns.
Posted Oct 28, 2021 - 13:46 PDT
Identified
Airship is currently experiencing delayed email delivery due to an outage with a third-party provider. This outage currently affects only customers using Airship's US site.

Retries should not be attempted at this time in order to mitigate potential duplicate deliveries.

We will provide updates here as we receive them.

Please feel free to contact Airship Technical Support at https://support.airship.com if you have any questions or concerns.
Posted Oct 28, 2021 - 11:10 PDT
Investigating
Since 10:50 AM Pacific time, we are investigating an issue involving these Airship services:

- Email Messaging

Our engineering team is working to identify and resolve this. We will update our status page as soon as we have more information.

Please feel free to contact Airship Technical Support at https://support.airship.com if you have any questions or concerns.
Posted Oct 28, 2021 - 10:50 PDT
This incident affected: Email Messaging.