Delay to Tag updates
Incident Report for Airship
Postmortem

Between approximately 10:28 PM 15 May and 4:58 AM 16 May US Pacific time, updates to our tag system on our US site were delayed more than one hour. Customers may have noticed that device information was not updated as quickly as usual when retrieved, and messages targeting tags may have not included devices/named users where those tags had recently been added. Similarly, messages may have been delivered to devices/named users where tags were recently removed. No other systems were impacted. This was due to an unexpected burst in traffic, which was mitigated. Our engineering team is also improving the underlying system so that similar traffic spikes of this shape will be handled more efficiently, avoiding delays. We apologize for any inconvenience.

Posted May 19, 2021 - 08:52 PDT

Resolved
This issue has been resolved. Tag updates are now being processed as expected in our system.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted May 16, 2021 - 04:59 PDT
Monitoring
We have implemented a fix to our tag update services and are actively monitoring the results. We continue to see improvement with delayed tag updates, however, notifications to segmented audiences may still be inaccurate as some tags may not have updated in our system yet.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted May 16, 2021 - 04:39 PDT
Update
We are continuing to investigate this issue.
Posted May 16, 2021 - 03:29 PDT
Update
We are continuing to investigate this issue. Tag updates are currently delayed up to three hours. Notifications to segmented audiences may be inaccurate as some tags may not have updated in our system yet.

If you have any questions or concerns please contact Airship Technical Support at Airship Support
Posted May 16, 2021 - 00:46 PDT
Investigating
We are currently investigating an issue that is causing tag updates to be delayed by more than an hour. Notifications to segmented audiences may be inaccurate as some tags may not have updated in our system yet.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted May 15, 2021 - 23:22 PDT
This incident affected: Targeting & Personalization.