Delays in updates to Named Users
Incident Report for Airship
Postmortem

Between approximately 12:03 AM and 7:28 AM US Pacific time on 18th January, updates to associate and disassociate named users from channels and to add or remove tags on named users may have been delayed between 60 and 406 minutes, due to a spike in traffic. This would have also impacted any automated messages that trigger off of these named user associations or tag updates. We are investigating ways to better handle traffic spikes for this service and apologize for any inconvenience this may have caused.

Posted Apr 16, 2020 - 11:54 PDT

Resolved
We have resolved an issue that resulted in delays in updates to Named Users. Updates to Named User Associations and Named user tags may have been delayed. Push notifications still sent at a normal rate, but possibly with outdated data.

Our engineering implemented a fix at approximately 6:48 AM PST and the backlog has been caught up.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Jan 18, 2020 - 07:41 PST
This incident affected: www.airship.com, APIs, Mobile Messaging, Web Notifications, and Targeting & Personalization.