Scheduled Message Center Messages not being delivered
Incident Report for Airship
Postmortem

Scheduled messages that included message center as part of their payloads may not have been delivered if they were created between approximately 3:25 PM US Pacific time on 19 March and 3:08 PM on 21 March. By 3:40 PM, all remaining scheduled messages created during this period were repaired so they would be able to be delivered successfully. This defect was introduced as part of major changes to our scheduling system, which will improve its queueing services and make it much more flexible and reliable in the future. Future changes to this system should be easier to test and less likely to cause unexpected errors. We apologize for any inconvenience.

Posted Mar 24, 2021 - 07:29 PDT

Resolved
We have resolved the issue which prevented scheduled Message Center messages from being sent.

Any previously-scheduled Message Center messages with a send date in the future, as well as any newly-scheduled Message Center messages, will now send successfully.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Mar 22, 2021 - 15:57 PDT
Identified
Our engineers have released a fix for all newly-scheduled Message Center messages.

We are continuing to work toward a fix for previously-scheduled Message Center messages that have not yet passed their scheduled send time.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Mar 22, 2021 - 15:10 PDT
Update
We are continuing to investigate an issue that is resulting in scheduled Message Center messages not be delivered.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Mar 22, 2021 - 13:49 PDT
Investigating
We are currently investigating an issue that is resulting in scheduled Message Center messages to segments not be delivered.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Mar 22, 2021 - 13:13 PDT
This incident affected: Message Center Messaging.