Named User association delayed by an hour or more
Incident Report for Airship
Postmortem

Between approximately 10:52 AM and 11:36 AM US Pacific time on 15 October, named user associations/disassociations and tag updates on named users may have been delayed over one hour. This was due to increased load on our systems cased by a batch script that was improperly utilizing our APIs. We remediated the issue by scaling for additional capacity, and we will also be investigating code changes that reduce the need for additional capacity from similar API usage. We apologize for any inconvenience.

Posted Oct 16, 2020 - 08:32 PDT

Resolved
We have resolved the issue which has resulted in delays to named user associations.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 15, 2020 - 12:15 PDT
Monitoring
We have implemented a fix to adjust for the delays in our system. Named user association time is currently under an hour and trending down at this time. We are continuing to actively monitor the progression.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 15, 2020 - 11:59 PDT
Identified
We have identified an issue that is resulting in Named user association delays greater than one hour. Our engineers are actively working on resolving this issue.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 15, 2020 - 11:29 PDT
This incident affected: Targeting & Personalization.