Push delays on October 08, 2020
Incident Report for Airship
Postmortem

Between approximately 5:34PM and 6:13PM US Pacific time on 7 October, customers on our US cloud site may have noticed push delivery delays of over 5 minutes beyond normal levels on their projects. Customers may have also seen delays over 10 minutes between 5:56PM and 6:11PM, peaking at ~12.1 minutes beyond normal levels. These delays were unexpected consequences of a deploy, which was rolled back quickly by our Engineering team once our alerting notified us of an issue. We are still investigating why these impacts resulted from the code change exactly, and we will be following up with a Root Cause Analysis and planned mitigations once that investigation is complete.

Posted Oct 09, 2020 - 12:13 PDT

Resolved
We have resolved an issue that resulted in up to 12-minute delays for pushes sent on October 08, 2020 between 00:56 UTC and 01:11 UTC.

Our engineering team is currently investigating the root cause.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Oct 07, 2020 - 18:30 PDT