Elevated rate of errors from Named User API
Incident Report for Airship
Postmortem

Between approximately 10:09 AM US Pacific time on 26 February and 7:22 PM US Pacific time on 27 February, customers on our US cloud site at go.urbanairship.com/go.airship.com may have experienced intermittent elevated 5xx error responses from our named user API system. This was particularly severe between 2:12 PM and 3:12 PM on the 27th. Our Engineering team determined that this was due to a recent configuration change having unintended impacts on how our central authorization system communicates with this particular API. We were able to resolve the issue by rolling back to the previous configuration. We have also opened a ticket with our cloud provider to inquire as to whether recent maintenance may have also contributed. We apologize for any inconvenience, and recommend setting up retry mechanisms for this API that utilize exponential backoff in order to make sure all of your named user updates are processed successfully.

Posted Mar 01, 2021 - 14:25 PST

Resolved
Changes resulting from updates to Airship's authentication services continue to be successful and are resulting in a reduction of errors from the Named User API. This incident is now resolved.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Feb 27, 2021 - 18:00 PST
Monitoring
Updates to Airship API authentication services were successful. We are now monitoring the results of these changes.
Posted Feb 27, 2021 - 17:26 PST
Update
Airship is performing configuration changes to its authentication services in an effort to mitigate continued API errors. Airship APIs may be unreachable for several minutes and may return errors during this window. We will post a status update at the conclusion of this event.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Feb 27, 2021 - 17:19 PST
Investigating
We are currently investigating an issue that is resulting in an increased rate of errors from the Named User API.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Feb 27, 2021 - 15:12 PST
This incident affected: APIs.