Throttled message delays
Incident Report for Airship
Postmortem

Between approximately 11:03AM and 6:20PM US Pacific time on 9 April, customers on our US cloud site who send throttled pushes may have experienced significant delivery delays and possible dropped messages. Our Engineering team is investigating the root cause and working on mitigations, including adding alerting so we will become aware of a similar problem much more quickly in the future. We apologize sincerely for any inconvenience, and please feel free to reach out to our support team at https://support.airship.com with any questions.

Posted Apr 14, 2020 - 12:03 PDT

Resolved
The issue that resulted in delays with pushes sent using our throttling service has been resolved. Pushes are expected to continue to send but at their normal rate limit. All services are now working as expected.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Apr 09, 2020 - 18:25 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2020 - 18:03 PDT
Investigating
We are currently investigating an issue that is resulting in delays for pushes sent using the throttling service. Notifications that have a rate limit set are significantly delayed at this time. All other services are working as expected.

If you have any questions or concerns please contact Airship Technical Support at support.airship.com
Posted Apr 09, 2020 - 17:24 PDT
This incident affected: Mobile Messaging and Web Notifications.