Messages reports fail to load
Incident Report for Airship
Postmortem

Between approximately 4:15 PM on 27 January 2020 and 7:27 AM on 28 January 2020 US Pacific time, the message detail pages in the Airship dashboard that display reporting data for each notification were failing to load. This was an unexpected impact of a code change. Data was still available from the main messages page and via our reporting APIs. We apologize for the inconvenience, and our Engineering team will be investigating how to avoid similar problems in the future.

Posted Mar 27, 2020 - 08:17 PDT

Resolved
We have resolved the issue which caused a failure when attempting to load our Push Report page.

If you have any additional questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Jan 28, 2020 - 07:53 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2020 - 07:46 PST
Identified
We have identified an issue which has caused our Push Reports to fail to load. All other services are working as expected.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

If you have any additional questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted Jan 28, 2020 - 07:41 PST
Investigating
We are investigating an issue that is causing Message Reports to fail to load in the Airship Dashboard. Message delivery is not affected at this time.

If you have any questions or concerns please contact Airship Support at support.airship.com
Posted Jan 28, 2020 - 07:15 PST
This incident affected: Analytics and Data Solutions (Engagement Reporting).