Elevated 5xx Errors for Wallet APIs
Incident Report for Airship
Postmortem

Between approximately 7:00 AM September 2 until 11:23 AM September 3 US Pacific time, customers on our US cloud site may have experienced slow response times and elevated errors from the Wallet API and Wallet-related pages on our web dashboard. This was particularly severe between 1:54 PM and 8:00 PM on September 2, and between 4:03 AM and 11:23 AM on September 3. This was due to an increase in a particular new pattern of traffic, which revealed a long-standing bug that was slowing down the Wallet system. We will be conducting a full root cause analysis, and we apologize for any inconvenience this incident may have caused.

Posted Sep 08, 2021 - 07:51 PDT

Resolved
We have resolved the issue that resulted in elevated 5xx errors on our Wallet APIs. All APIs are now working as expected.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Sep 02, 2021 - 14:31 PDT
Identified
Our engineers have identified the root cause of the issue and are currently working toward a fix.

We will update our status page as soon as there is additional information.
Posted Sep 02, 2021 - 13:46 PDT
Investigating
We are currently investigating an issue that is resulting in elevated 5xx errors on our Wallet APIs. All other APIs are working as expected.

Our engineers are currently working to resolve this issue. We will update our status page as soon as there is additional information.
Posted Sep 02, 2021 - 12:33 PDT
This incident affected: Mobile Wallet Passes.