Message Center delivery delays
Incident Report for Airship
Postmortem

Between approximately 10:05 AM and 11:54 AM on 25 October, deliveries on our US site that included message center messages may have been delayed over an hour. We also experienced elevated error levels on our user API endpoints, which are used by our mobile SDKs to retrieve message center messages, from 9:00 AM until the end of the incident. This was due to a performance issue related to a spike in traffic. Our Engineers resolved the incident by increasing resources to the relevant system and its database, and those resources will remain at this elevated level until our planned long-term fix is in place. We apologize for any inconvenience.

Posted Oct 26, 2021 - 11:15 PDT

Resolved
This issue is now resolved. If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 25, 2021 - 11:57 PDT
Update
We are continuing to investigate this issue.
Posted Oct 25, 2021 - 11:57 PDT
Investigating
We are currently investigating an issue that is resulting in Message Center delivery delays and an increased error rate from Airship's User API.

Users sending Message Center messages, including push notifications associated with Message Center messages, may experience delays of over one hour.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 25, 2021 - 10:53 PDT
This incident affected: APIs and Message Center Messaging.