Errors in the Wallet API and Wallet Dashboard
Incident Report for Airship
Postmortem

Between approximately 12:58-1:28PM and 1:52-3:52 PM US Pacific time on 3 June, customers using our US cloud site may have experienced high levels of 5xx errors from our Wallet APIs, as well as slowness or errors on Wallet-related pages of our web dashboard. This was caused by a defect injected during a standard maintenance process that was resolved by returning to a known stable version of the code. Our Engineering team continues to research why these impacts occurred and how to prevent similar recurrences in the future. We apologize for any inconvenience.

Posted Jun 15, 2021 - 09:50 PDT

Resolved
We have resolved the issue that resulted in a high number of 5xx errors when using our Wallet APIs and customers should no longer be experiencing slowness or encountering errors while in the Wallet section of the Airship Dashboard.

All Airship systems are functioning as expected.

If you have questions or concerns please contact Airship Technical Support at support.airship.com
Posted Jun 03, 2021 - 16:21 PDT
Monitoring
Our engineers have implemented a fix and are currently monitoring the results.

If you have questions or concerns please contact Airship Technical Support at support.airship.com
Posted Jun 03, 2021 - 15:58 PDT
Investigating
We are currently investigating an issue that is resulting in a high number of 5xx errors when using our Wallet APIs.

Customers may also see errors when attempting to load Wallet projects and Wallet templates in the Airship Dashboard. Customers may also experience general slowness on the main Wallet projects page.

All other Airship systems are functioning as expected.

We will update this status page as soon as we have more information. If you have questions or concerns please contact Airship Technical Support at support.airship.com
Posted Jun 03, 2021 - 14:56 PDT
This incident affected: Web Dashboard and Mobile Wallet Passes.