Extended Delays for Unicast and Segmented Messages
Incident Report for Airship
Postmortem

Between approximately 12:33 PM and 3:46 PM US Pacific time on 6 October, customers on our US cloud site may have experienced push delivery delays of up to 31 minutes. Device changes to opt-in status and badge count may have also been delayed over an hour in processing between approximately 12:33 PM and 5:21 PM. This was due to a very large increase in a particular kind of sending behavior. We have implemented changes such that we will be able to block future problematic behavior to the impacted service much more quickly, and we will be investigating other mitigations in the coming days. We sincerely apologize for any inconvenience.

Posted Oct 08, 2021 - 11:38 PDT

Resolved
This issue is now resolved.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 06, 2021 - 15:52 PDT
Investigating
We're actively investigating an issue that is resulting in delayed unicast and segmented messages. All other services are working as intended.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com
Posted Oct 06, 2021 - 13:41 PDT
This incident affected: Mobile Messaging.