Errors in In App Automation lookup
Incident Report for Airship
Postmortem

Between approximately 10:04 AM and 3:54 PM US Pacific time on 18 June, in-app automations may not have been viewable, particularly those targeting static lists. This was due to increased load that was not correctly mitigated by our auto-scaling services. The system recovered after our Engineering team made improvements, and they are continuing to explore further improvements to avoid recurrences. We apologize for any inconvenience.

Posted Jun 22, 2021 - 14:32 PDT

Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 17:35 PDT
Identified
We have identified an issue with our In-App Message target validation system, which is causing lag in the system. In-App Automations targeting static lists were specifically affected.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Jun 18, 2021 - 14:46 PDT
Investigating
We are currently investigating an issue that is causing In-App Automations to fail to display on devices.

Other push services including regular automations are working as expected.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Jun 18, 2021 - 13:19 PDT
This incident affected: APIs.