Elevated rate of 5xx Errors from Airship API and Go Dashboard
Incident Report for Airship
Postmortem

Beginning around 3:20PM US Pacific time on 18 September, Airship push APIs may have been unavailable. They recovered on the US cloud site (go.urbanairship.com) around 4:00PM, and on the EU cloud site (go.airship.eu) around 4:12PM. Pushes that were already scheduled should not have been impacted. This incident was due to a bug in our software deploy process that will be fixed before any further major deploys. We will also be investing in other proportional investments associated with the root causes of both the incident and system's delayed recovery. We sincerely apologize for any inconvenience.

Posted Sep 21, 2020 - 12:14 PDT

Resolved
We have resolved the issue that resulted in increased error rate on our APIs and Go Dashboard. All services should be functioning as normal.
Posted Sep 18, 2020 - 16:15 PDT
Monitoring
We have identified the issue that is resulting in an increased rate of 5xx errors when sending push notifications from the API and the Go Dashboard.

Our engineering teams have deployed a fix and our systems are recovering to normal functionality imminently.
Posted Sep 18, 2020 - 16:09 PDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2020 - 15:50 PDT
Investigating
We are currently investigating an issue that is resulting in an increased rate of 5xx errors when sending push notifications from the API and the Go Dashboard.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Sep 18, 2020 - 15:48 PDT
This incident affected: Web Dashboard and APIs.