Slightly increased rate of 5xx errors for pushes sent or scheduled through the API
Incident Report for Airship
Postmortem

Between about 6:30 AM and 10:42 AM US Pacific time on 28 May, customers may have experienced intermittent elevated 5xx errors to our push API endpoints, including /api/push, /api/schedules, /api/templates, and /api/create-and-send. Our Engineering team implemented configuration changes that have greatly reduced the number of errors, resolving this incident. We apologize for any inconvenience, and will continue to make other improvements and continue to monitor this system’s performance going forward.

Posted Jun 02, 2020 - 08:56 PDT

Resolved
We have resolved the issue that resulted in a slightly increased rate of 5xx errors when sending or scheduling push notifications from the API.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted May 28, 2020 - 11:31 PDT
Investigating
We are currently investigating an issue that is resulting in a slightly increased rate of 5xx errors when sending or scheduling push notifications from the API.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com/
Posted May 28, 2020 - 11:06 PDT
This incident affected: APIs.