Delays for Unicast and Segmented Messages
Incident Report for Airship
Postmortem

Between approximately 1:47 PM and 2:25 PM US Pacific time on 20 October, customers on our US cloud site may have experienced push delivery delays of up to 16 minutes. Registration updates to badge count and opt-in status may have also been delayed over an hour in processing between approximately 1:03 PM and 3:08 PM. This was due to a very large increase in a particular kind of sending behavior. We resolved the issue by blocking the problematic traffic, and we will continue working on other mitigations to prevent further recurrences in the coming days. We sincerely apologize for any inconvenience.

Posted Oct 20, 2021 - 17:00 PDT

Resolved
This issue is now resolved.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 20, 2021 - 15:12 PDT
Monitoring
We are now monitoring this issue. Message delivery delays have been resolved, but there may be delays in registration updates for opt-in statuses and app badging.
Posted Oct 20, 2021 - 14:38 PDT
Investigating
We're actively investigating an issue that is resulting in delayed unicast and segmented messages.

Our engineering teams are working to resolve this issue. We will update our status page as soon as we have more information.

If you have any questions or concerns, please contact Airship Technical Support at https://support.airship.com
Posted Oct 20, 2021 - 14:12 PDT
This incident affected: Mobile Messaging.