500 errors with Channel Registrations and Channel Lookups
Incident Report for Airship
Postmortem

Between approximately 9:38 AM and 10:30 AM US Pacific time on 19 June, Airship's channel registration, listing, and lookup APIs were serving a high percentage of errors. This was due to increased system load, which will be improved by a configuration change we are planning to make shortly to update some foundational software. No other APIs were impacted, and devices should have automatically retried making any updates. We apologize for any inconvenience.

Posted Jun 23, 2020 - 08:13 PDT

Resolved
We have resolved the issue that was resulting in 500 errors for channel registration, listing, and lookup within our system.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Jun 19, 2020 - 10:40 PDT
Investigating
We are currently investigating an issue that is causing a large number of 5XX errors for channel (device) registration, listing, lookup within our system. Notifications sent through the API and Go Dashboard are working as expected at this time.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Jun 19, 2020 - 10:24 PDT
This incident affected: APIs.