Send Reporting Delays in USCS
Incident Report for Airship
Postmortem

Between approximately 2:20 AM and 9:35 AM Pacific time on 11 October, customers on our US cloud site may have experienced send reporting delays of over 2 hours. Additionally, it may have taken until around 1:45 PM for missing data from the impacted period to be repaired. This was due to a bug in a third-party library we utilize, which we will be updating. We apologize for any inconvenience.

Posted Oct 14, 2021 - 10:24 PDT

Resolved
This issue is now resolved. Our engineering team is currently repairing missing data from the impacted period, but all new send data should be working as intended.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 11, 2021 - 10:01 PDT
Monitoring
Our engineering team has identified a possible root cause of the issue and is currently monitoring the results.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com
Posted Oct 11, 2021 - 09:50 PDT
Investigating
We are currently investigating an issue that is resulting in send reporting metric delays for US customers. This does not impact any other services.

Our engineers are currently working to resolve this issue. We will update our status page as soon as there is additional information.

If you have any questions or concerns please contact Airship Technical Support at https://support.airship.com/
Posted Oct 11, 2021 - 09:31 PDT
This incident affected: Analytics and Data Solutions (Engagement Reporting).